$wpsc_version = 169; a transducer must be